Perch Update 1.2.6

We’ve updated Perch with a small number bug fixes for issues discovered via our support system.

This update includes the fixes and features in the Perch 1.2 and 1.2.5 updates.

Do I need to install this?

This is a recommended update for users running PHP 5.3, but otherwise there’s no need to install immediately. You should update when it’s next convenient to do so.

What does it fix?

This release fixes the below issues:

  • A number of minor compatibility issues that cause deprecation warnings to be displayed for servers running PHP 5.3 or greater.
  • Mitigates an issue where duplicate regions can cause content not to display.

What features does it add?

This is purely a bug fix release, and adds no new features. There is no need to update unless you are experiencing any of the issues detailed above.

What impact does it have for my clients?

Users will not see any significant differences unless they’ve been having problems with the above bugs.

Where do I get the update?

Log into your account and re-download the files. The download has been replaced with the newest version.

Make a back-up of your files. Unzip and replace your existing files with the exception of:

  • config
  • resources
  • templates
  • plugins – if you have added to this

These contain information specific to your installation and should not be overwritten. There is no need to copy setup, as you’re already up and running.

If you are updating from a version older than 1.2 visit /perch/update in your browser.

That’s all you need to do – Perch is now updated.

Previous updates